Domov      Nastavenia 
RSS English Slovensky

Zahraničné zdroje
Nahlásené incidenty
1.1.2020 - 31.12.2020
 

Graf

V produkte Cisco Jabber bolo opravených 5 zraniteľností

29.03.2021
Spoločnosť Cisco vydala záplatu pre 5 zraniteľností vyskytujúcich sa v produkte Cisco Jabber pre Windows, MacOS a mobilné platformy. Kritická zraniteľnosť je spôsobená nesprávnym overovaním obsahu XMPP správy, čo môže viesť ku vzdialenému vykonávaniu kódu. Zneužitím zvyšných 4 chýb môže dôjsť tiež ku vzdialenému vykonaniu kódu, úniku citlivých informácií alebo narušeniu dostupnosti služby.

 

Dôsledky

  • Vzdialené vykonávanie kódu
  • Možný únik citlivých informácií
  • Vykonanie DoS útoku
  • Zachytenie sieťovej prevádzky
  • Úprava sieťových spojení

Opis činnosti
CVE-2021-1411, CVE-2021-1417, CVE-2021-1418, CVE-2021-1469, CVE-2021-1471

Spoločnosť Cisco v produkte Cisco Jabber opravila 5 zraniteľností, z čoho 1 je kritická. Chyby spolu nesúvisia, a zneužitie ktorejkoľvek z nich nezávisí od zneužitia inej chyby.

Kritická zraniteľnosť CVE-2021-1411 nachádzajúca sa v klientovi pre Windows dosahuje CVSS skóre 9.9. Zraniteľnosť je spôsobená nesprávnym overovaním obsahu XMPP správy. Vzdialený autentifikovaný útočník môže túto chybu zneužiť tak, že pošle špeciálne vytvorené XMPP správy zraniteľnému softvéru a následne vykoná ľubovoľný kód s oprávneniami aktuálne prihláseného používateľa.

Popri kritickej zraniteľnosti spoločnosť opravila aj ďalšie 2 zraniteľnosti v Cisco Jabber pre Windows. Obe chyby súvisia s nesprávnym overovaním obsahu XMPP správy. Úspešným zneužitím závažnej zraniteľnosti CVE-2021-1417 by mohlo dôjsť k úniku citlivých informácií. Vzdialený útočník so špeciálne zabezpečeným účtom na serveri XMPP môže chybu CVE-2021-1469 zneužiť tak, že pošle vytvorené XMPP správy zraniteľnému softvéru. Zneužitím môže dôjsť k vykonaniu ľubovoľného kódu.

Ďalšie zraniteľnosti sa nachádzajú v Cisco Jabber pre Windows, MacOS a mobilné platformy. CVE-2021-1418 je chyba vyplývajúca z nesprávneho overenia obsahu správy, ktorá by mohla byť zneužitá pri odosielaní špeciálne vytvorených správ XMPP. Zneužitím môže dôjsť k narušeniu dostupnosti služby (DoS). CVE-2021-1471 je zraniteľnosť týkajúca sa nesprávneho overovania certifikátov. Je možné ju zneužiť na zachytenie sieťovej prevádzky a tiež na úpravu spojení medzi klientom Cisco Jabber a serverom.

Zraniteľné systémy

  • Cisco Jabber pre Windows verzie 12.1 a nižšej, 12.5, 12.6, 12.7, 12.8 a 12.9
  • Cisco Jabber pre MacOS verzie 12.7 a nižšej, 12.8 a 12.9
  • Cisco Jabber pre Android a iOS verzie 12.9 a nižšej
  • Cisco Jabber pre BlackBerry a Cisco Jabber pre Intune MAM verzie 12.9

Závažnosť zraniteľnosti
Vysoká

Možné škody
Vzdialené vykonávanie kódu
Únik citlivých informácií
Narušenie dostupnosti systému (DoS)

Odporúčania
Odporúčame bezodkladnú aktualizáciu na najnovšie dostupné verzie. V prípade verzií 12.1 pre Windows, 12.7 pre MacOS a 12.9 pre Android a iOS odporúčame migráciu na stabilné verzie.

Odkazy
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-cisco-jabber-PWrTATTC
https://www.bleepingcomputer.com/news/security/cisco-addresses-critical-bug-in-windows-macos-jabber-clients/
https://thehackernews.com/2021/03/critical-cisco-jabber-bug-could-let.html



<< zoznam oznámení