Domov      Nastavenia 
RSS English Slovensky

Zahraničné zdroje
Nahlásené incidenty
1.1.2020 - 31.12.2020
 

Graf

Zraniteľnosti v jadre systému Linux objavené po 15 rokoch

29.03.2021
Kyberbezpečnostná spoločnosť GRIMM zverejnila trojicu chýb, ktorú objavila v jadre operačného systému Linux. Zraniteľnosti sa nachádzajú v nepovšimnutom kóde, kde čakali celých 15 rokov. Útočníkom umožňujú eskalovať privilégiá, odcudziť informácie, či spôsobiť nedostupnosť služby.

 

Dôsledky

  • Kompromitácia operačného systému
  • Únik dát
  • Poškodenie systému
  • Kompromitácia infraštruktúry

Opis činnosti

CVE-2021-27365

Zraniteľnosť sa nachádza v jadre operačného systému Linux, konkrétne v niektorých dátových štruktúrach štandardu iSCSI. Neprivilegovaný používateľ môže zneužiť zraniteľnosť odoslaním správy Netlink, ktorá je spojená s iSCSI. Nedostatočným alebo chýbajúcim overením dĺžky, môže nastavením reťazca správy na hodnotu väčšiu, ako je dĺžka atribútu PAGE_SIZE s následným pokusom o jeho načítanie útočník spôsobiť pretečenie medzipamäte na halde. Útočník by tak mohol eskalovať svoje privilégiá, spôsobiť zlyhanie operačného systému Linux, odcudziť či meniť dáta alebo eskalovať svoje privilégiá v zraniteľnom systéme.

CVE-2021-27363

Zraniteľnosť ovládača iSCSI v jadre operačného systému Linux sa nachádza v spôsobe spracovania prístupu k reláciám a v manipulácii s dátami, ktoré ovládač spracováva. Zraniteľnosť umožňuje používateľovi bez oprávnení používateľa root získať prístup k dátam spracovávaných iSCSI. Útočník by tak mohol získať prístup k potencionálne citlivým dátam, alebo aj v kombinácii s inými zraniteľnosťami zvýšiť svoje oprávnenia v systéme a spôsobiť rozsiahle škody.

CVE-2021-27364

Zraniteľnosť sa nachádza v jadre operačného systému Linux, konkrétne v module libiscsi. Zraniteľnosť umožňuje neprivilegovanému útočníkovi čítať pamäť alokovanú jadru systému, pripojiť sa k jadru, vytvárať správy Netlink a odosielať ich jadru na spracovanie. Zraniteľnosť môže byť zneužitá útočníkom na eskaláciu oprávnení v systéme.

Zraniteľné systémy

  • Všetky verzie operačného systému Linux

Závažnosť zraniteľnosti
Vysoká

Možné škody
Neoprávnený prístup do systému
Únik citlivých informácií

Odporúčania
Bezodkladná aktualizácia jadra používaného operačného systému Linux aspoň na verziu 5.11.4, 5.10.21, 5.4.103, 4.19.179, 4.14.224, 4.9.260, alebo 4.4.260.

Odkazy
https://www.cybersecurity-help.cz/vdb/SB2021031502
https://lists.debian.org/debian-lts-announce/2021/03/msg00010.html
https://nakedsecurity.sophos.com/2021/03/17/serious-security-the-linux-kernel-bugs-that-surfaced-after-15-years/amp/
https://www.bleepingcomputer.com/news/security/15-year-old-linux-kernel-bugs-let-attackers-gain-root-privileges/



<< zoznam oznámení